Brad Bishop | 02f8e88 | 2016-04-15 09:23:44 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor python library" |
| 2 | DESCRIPTION = "Phosphor python library." |
Brad Bishop | 0239063 | 2016-06-09 01:26:47 -0400 | [diff] [blame] | 3 | HOMEPAGE = "http://github.com/openbmc/pyphosphor" |
Brad Bishop | 02f8e88 | 2016-04-15 09:23:44 -0400 | [diff] [blame] | 4 | PR = "r1" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 7 | |
| 8 | inherit allarch |
| 9 | inherit setuptools |
Brad Bishop | 1b4e447 | 2016-08-29 21:47:04 -0400 | [diff] [blame] | 10 | inherit python-dir |
| 11 | |
| 12 | PACKAGE_BEFORE_PN = " \ |
| 13 | ${PN}-ns \ |
| 14 | ${PN}-utils-ns \ |
| 15 | ${PN}-dbus-ns \ |
Brad Bishop | 56fa348 | 2016-08-29 21:51:58 -0400 | [diff] [blame] | 16 | ${PN}-wsgi-ns \ |
| 17 | ${PN}-wsgi-apps-ns \ |
Brad Bishop | 1b4e447 | 2016-08-29 21:47:04 -0400 | [diff] [blame] | 18 | ${PN}-utils \ |
| 19 | ${PN}-dbus \ |
| 20 | " |
| 21 | |
| 22 | RDEPENDS_${PN}-utils-ns += "${PN}-ns" |
| 23 | RDEPENDS_${PN}-dbus-ns += "${PN}-ns" |
| 24 | RDEPENDS_${PN}-utils += "${PN}-utils-ns" |
Brad Bishop | 56fa348 | 2016-08-29 21:51:58 -0400 | [diff] [blame] | 25 | RDEPENDS_${PN}-wsgi-apps-ns += "${PN}-wsgi-ns" |
| 26 | RDEPENDS_${PN}-wsgi-ns += "${PN}-ns" |
Brad Bishop | 1b4e447 | 2016-08-29 21:47:04 -0400 | [diff] [blame] | 27 | RDEPENDS_${PN}-dbus += " \ |
| 28 | ${PN}-dbus-ns \ |
| 29 | python-dbus \ |
| 30 | python-xml \ |
| 31 | python-json \ |
| 32 | python-pickle \ |
| 33 | " |
| 34 | RDEPENDS_${PN} += " \ |
| 35 | ${PN}-ns \ |
| 36 | ${PN}-dbus \ |
| 37 | python-subprocess \ |
| 38 | python-dbus \ |
| 39 | " |
| 40 | |
| 41 | FILES_${PN}-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/__init__.py*" |
| 42 | FILES_${PN}-utils-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/utils/__init__.py*" |
| 43 | FILES_${PN}-dbus-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/dbuslib/__init__.py*" |
Brad Bishop | 56fa348 | 2016-08-29 21:51:58 -0400 | [diff] [blame] | 44 | FILES_${PN}-wsgi-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/wsgi/__init__.py*" |
| 45 | FILES_${PN}-wsgi-apps-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/wsgi/apps/__init__.py*" |
Brad Bishop | 1b4e447 | 2016-08-29 21:47:04 -0400 | [diff] [blame] | 46 | |
| 47 | FILES_${PN}-utils = "${PYTHON_SITEPACKAGES_DIR}/obmc/utils" |
| 48 | FILES_${PN}-dbus = "${PYTHON_SITEPACKAGES_DIR}/obmc/dbuslib" |
Brad Bishop | 02f8e88 | 2016-04-15 09:23:44 -0400 | [diff] [blame] | 49 | |
| 50 | SRC_URI += "git://github.com/openbmc/pyphosphor" |
| 51 | |
Brad Bishop | 56fa348 | 2016-08-29 21:51:58 -0400 | [diff] [blame] | 52 | SRCREV = "654526d526eb7083d1194b509404ffa7bb54915b" |
Brad Bishop | 02f8e88 | 2016-04-15 09:23:44 -0400 | [diff] [blame] | 53 | |
| 54 | S = "${WORKDIR}/git" |