blob: 5b0ca6041b01155296f28f0c3911647be6137883 [file] [log] [blame]
Marri Devender Rao5add2342017-06-08 03:17:36 -05001SUMMARY = "Generate inventory map for phosphor-ipmi-host from a MRW."
2PR = "r1"
3
4inherit native
5inherit phosphor-ipmi-host
6
7require phosphor-ipmi-host.inc
8
9DEPENDS += "mrw-native mrw-perl-tools-native"
10
11DEPENDS += "virtual/phosphor-ipmi-fru-hostfw-config"
12PROVIDES += "virtual/phosphor-ipmi-fru-read-inventory"
13
Marri Devender Raod2953df2017-07-05 12:19:52 -050014S = "${WORKDIR}/git"
15
Marri Devender Rao5add2342017-06-08 03:17:36 -050016do_install() {
17
18 DEST=${D}${config_datadir}
19 install -d ${DEST}
20
21 ${bindir}/perl-native/perl \
22 ${bindir}/gen_ipmi_fru.pl \
23 -i ${datadir}/obmc-mrw/${MACHINE}.xml \
24 -m ${hostfw_datadir}/config.yaml \
25 -o ${DEST}/config.yaml
26}