blob: 015f83cb01457e998bed2895ea1b1b4232605b11 [file] [log] [blame]
Andrew Geisslerc633d232017-01-17 15:08:44 -06001SUMMARY = "Phosphor Chassis State Management"
2DESCRIPTION = "Phosphor Chassis State Manager provides a chassis state \
3object which manages the chassis's in the system. It is suitable for use on \
4a wide variety of OpenBMC platforms."
5HOMEPAGE = "https://github.com/openbmc/phosphor-state-manager"
6PR = "r1"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10inherit autotools pkgconfig
11inherit obmc-phosphor-dbus-service
12
13DBUS_SERVICE_${PN} += "xyz.openbmc_project.State.Chassis.service"
14
15RDEPENDS_${PN} += "libsystemd"
16DEPENDS += "autoconf-archive-native"
17DEPENDS += "sdbusplus"
18DEPENDS += "phosphor-logging"
19
20PROVIDES += "virtual/obmc-chassis-state-mgmt"
21RPROVIDES_${PN} += "virtual-obmc-chassis-state-mgmt"
22
23SRC_URI += "git://github.com/openbmc/phosphor-state-manager"
Patrick Williams6c105ed2017-01-19 15:50:04 -060024SRCREV = "6e0b50936735faac96db2f20fe84ffd0733750a9"
Andrew Geisslerc633d232017-01-17 15:08:44 -060025
26S = "${WORKDIR}/git"