blob: f97664f20a84097f3ae75c301989bc8c42b5bb5a [file] [log] [blame]
Brad Bishop6f75a622019-02-04 14:28:33 -05001FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += " file://pam.d/common-password \
4 file://pam.d/common-account \
5 file://pam.d/common-auth \
6 "
7
8RDEPENDS_${PN}-runtime += "${MLPREFIX}pam-plugin-cracklib-${libpam_suffix} \
9 ${MLPREFIX}pam-plugin-tally2-${libpam_suffix} \
10 ${MLPREFIX}pam-plugin-pwhistory-${libpam_suffix} \
11 "
12
Matt Spinler34572662018-10-16 11:32:13 -050013do_install_append() {
14 # The libpam recipe will always add a pam_systemd.so line to
15 # common-session if systemd is enabled; however systemd only
16 # builds pam_systemd.so if logind is enabled, and we disable
17 # that package. So, remove the pam_systemd.so line here.
18 sed -i '/pam_systemd.so/d' ${D}${sysconfdir}/pam.d/common-session
19}