Patrick Venture | db1cc9b | 2018-09-20 19:27:13 -0700 | [diff] [blame] | 1 | HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-blobs" |
| 2 | SUMMARY = "Phosphor OEM IPMI BLOBS Protocol Implementation" |
| 3 | DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the BLOB protocol for sending and receiving data over IPMI." |
| 4 | PR = "r1" |
| 5 | PV = "0.1+git${SRCPV}" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 8 | |
| 9 | inherit autotools pkgconfig |
| 10 | inherit obmc-phosphor-ipmiprovider-symlink |
| 11 | |
| 12 | DEPENDS += "autoconf-archive-native" |
| 13 | DEPENDS += "phosphor-ipmi-host" |
Patrick Venture | 2b12094 | 2018-09-27 12:56:49 -0700 | [diff] [blame] | 14 | DEPENDS += "phosphor-logging" |
Patrick Venture | db1cc9b | 2018-09-20 19:27:13 -0700 | [diff] [blame] | 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | SRC_URI = "git://github.com/openbmc/phosphor-ipmi-blobs" |
Andrew Geissler | 0cfd8db | 2018-10-24 19:30:22 +0000 | [diff] [blame] | 18 | SRCREV = "e50d4e4aa5c77058b51a2f599cca6f391b6040da" |
Patrick Venture | db1cc9b | 2018-09-20 19:27:13 -0700 | [diff] [blame] | 19 | |
| 20 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 21 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 22 | FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| 23 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
| 24 | |
| 25 | HOSTIPMI_PROVIDER_LIBRARY += "libblobcmds.so" |