Rick Altherr | 9222093 | 2016-12-08 12:21:49 -0800 | [diff] [blame] | 1 | DESCRIPTION = "Small image capable of booting a device. The kernel includes \ |
| 2 | the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \ |
| 3 | first 'init' program more efficiently." |
| 4 | |
| 5 | PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} obmc-phosphor-initfs" |
| 6 | |
| 7 | # Do not pollute the initrd image with rootfs features |
| 8 | IMAGE_FEATURES = "" |
| 9 | |
| 10 | export IMAGE_BASENAME = "obmc-phosphor-initramfs" |
| 11 | IMAGE_LINGUAS = "" |
| 12 | |
| 13 | LICENSE = "MIT" |
| 14 | |
| 15 | IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}" |
| 16 | inherit core-image |
| 17 | |
| 18 | IMAGE_ROOTFS_SIZE = "8192" |
| 19 | IMAGE_ROOTFS_EXTRA_SPACE = "0" |
| 20 | |
| 21 | BAD_RECOMMENDATIONS += "busybox-syslog" |