blob: eb89efcce541e1089de94aaf4cd2d457c6411eb8 [file] [log] [blame]
Brad Bishop80fac6d2016-06-07 16:25:54 -04001SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
4SECTION = "bootloader"
5DEPENDS = "mtd-utils"
6
Joel Stanley7741d652016-07-27 18:33:40 +09307SRCREV = "f9b2a49f57c153c7358f9769234c0cefdf4de8d4"
8UBRANCH = "v2016.07-aspeed-openbmc"
Brad Bishop80fac6d2016-06-07 16:25:54 -04009SRC_URI = "git://git@github.com/openbmc/u-boot.git;branch=${UBRANCH};protocol=https"
10
Joel Stanley7741d652016-07-27 18:33:40 +093011PV = "v2016.07+git${SRCPV}"
Brad Bishop80fac6d2016-06-07 16:25:54 -040012
13S = "${WORKDIR}/git"
14
15INSANE_SKIP_${PN} = "already-stripped"
16EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
17EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
18
19inherit uboot-config
20
21do_compile () {
22 oe_runmake ${UBOOT_MACHINE}
23 oe_runmake env
24}
25
26do_install () {
27 install -d ${D}${base_sbindir}
28 install -d ${D}${sysconfdir}
29 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
30 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
31 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
32}
33
34do_install_class-cross () {
35 install -d ${D}${bindir_cross}
36 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
37 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
38}
39
40SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross"
41uboot_fw_utils_cross() {
42 sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
43}
44
45PACKAGE_ARCH = "${MACHINE_ARCH}"
46BBCLASSEXTEND = "cross"