blob: c8ae846694dbdb46f28304bbcc29312e35fc32f9 [file] [log] [blame]
Milton D. Miller II74901a12016-01-20 15:31:12 -06001#require recipes-bsp/u-boot/u-boot.inc
2
3SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
4SECTION = "bootloader"
5DEPENDS = "mtd-utils"
6
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
9 file://README;beginline=1;endline=22;md5=78b195c11cb6ef63e6985140db7d7bab"
10
11# This revision corresponds to the tag "v2013.07"
12# We use the revision in order to avoid having to fetch it from the
13# repo during parse
14# SRCREV = "62c175fbb8a0f9a926c88294ea9f7e88eb898f6c"
15SRCREV="${AUTOREV}"
16
17PV = "v2013.07+git${SRCPV}"
18
19UBRANCH = "v2013.07-aspeed-openbmc"
20SRC_URI = "git://git@github.com/openbmc/u-boot.git;branch=${UBRANCH};protocol=https"
21S = "${WORKDIR}/git"
22
23#INSANE_SKIP_${PN} = "already-stripped"
24#EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
25#EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
26EXTRA_OEMAKE = 'HOSTCC="${CC}" CC="${CC}" HOSTSTRIP="true"'
27
28inherit uboot-config
29
30do_compile () {
31 oe_runmake ${UBOOT_MACHINE}
32 oe_runmake env
33}
34
35do_install () {
36 install -d ${D}${base_sbindir}
37 install -d ${D}${sysconfdir}
38 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
39 ln -sf fw_printenv ${D}${base_sbindir}/fw_setenv
40 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
41}
42
43#do_install_class-cross () {
44# install -d ${D}${bindir_cross}
45# install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
46# install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
47#}
48
49#SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross"
50#uboot_fw_utils_cross() {
51# sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
52#}
53
54PACKAGE_ARCH = "${MACHINE_ARCH}"
55#BBCLASSEXTEND = "cross native"