blob: 0458b824571ef037bb38156c0cda3f2bbf4c2061 [file] [log] [blame]
Ratan Gupta74b00f32018-03-21 00:34:08 +05301FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += "file://avahi.conf"
4SRC_URI += "file://check-avahi-pre-cond.service"
5SRC_URI += "file://create-user"
6SRC_URI += "file://check-local-domain"
7
8RRECOMMENDS_${PN}-daemon += "bind-utils"
9
10AVAHI_SVC = "avahi-daemon.service"
11
12AVAHI_DROPIN_DIR = "${AVAHI_SVC}.d"
13
14FILES_${PN}-daemon_append += "${systemd_system_unitdir}/${AVAHI_DROPIN_DIR}/avahi.conf"
15
16PACKAGE_BEFORE_PN += "${PN}-daemon-preconditions"
17
18FILES_${PN}-daemon-preconditions += "${systemd_system_unitdir}/check-avahi-pre-cond.service"
19FILES_${PN}-daemon-preconditions += "${sbindir}/create-user"
20FILES_${PN}-daemon-preconditions += "${sbindir}/check-local-domain"
21
22RRECOMMENDS_${PN}-daemon += "${PN}-daemon-preconditions"
23
24do_install_append() {
25
26 mkdir -p ${D}/${systemd_system_unitdir}/${AVAHI_DROPIN_DIR}
27 install -m 0755 ${WORKDIR}/avahi.conf ${D}/${systemd_system_unitdir}/${AVAHI_DROPIN_DIR}/avahi.conf
28 install -m 0755 ${WORKDIR}/check-avahi-pre-cond.service ${D}/${systemd_system_unitdir}/check-avahi-pre-cond.service
29 install -m 0755 ${WORKDIR}/check-local-domain ${D}/${sbindir}/check-local-domain
30 install -m 0755 ${WORKDIR}/create-user ${D}/${sbindir}/create-user
31}