Artem Senichev | 8135af9 | 2018-11-02 16:46:13 +0300 | [diff] [blame] | 1 | SUMMARY = "Phosphor Host logger" |
| 2 | DESCRIPTION = "Save log messages from host's console to the persistent storage." |
| 3 | HOMEPAGE = "https://github.com/openbmc/phosphor-hostlogger" |
| 4 | PR = "r1" |
| 5 | PV = "1.0+git${SRCPV}" |
| 6 | |
| 7 | inherit autotools |
| 8 | inherit pkgconfig |
| 9 | inherit pythonnative |
| 10 | inherit systemd |
| 11 | |
| 12 | # License info |
| 13 | LICENSE = "Apache-2.0" |
| 14 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 15 | |
| 16 | # Dependencies |
Alexander Filippov | 74dc870 | 2019-01-10 12:38:09 +0300 | [diff] [blame] | 17 | DEPENDS += "\ |
| 18 | autoconf-archive-native \ |
| 19 | sdbusplus \ |
Artem Senichev | 8135af9 | 2018-11-02 16:46:13 +0300 | [diff] [blame] | 20 | sdbusplus-native \ |
Alexander Filippov | 74dc870 | 2019-01-10 12:38:09 +0300 | [diff] [blame] | 21 | phosphor-dbus-interfaces \ |
| 22 | " |
Artem Senichev | 8135af9 | 2018-11-02 16:46:13 +0300 | [diff] [blame] | 23 | RDEPENDS_${PN} += "obmc-console" |
| 24 | RRECOMMENDS_${PN} += "phosphor-debug-collector" |
| 25 | |
| 26 | # systemd service setup |
| 27 | SYSTEMD_PACKAGES = "${PN}" |
| 28 | SYSTEMD_SERVICE_${PN} = "hostlogger.service" |
| 29 | SYSTEMD_DEFAULT_TARGET ?= "multi-user.target" |
| 30 | |
| 31 | # Host TTY setup |
| 32 | OBMC_CONSOLE_HOST_TTY ?= "ttyVUART0" |
| 33 | |
| 34 | # Extra parameters for 'configure' script |
| 35 | EXTRA_OECONF = "HOST_TTY=${OBMC_CONSOLE_HOST_TTY} \ |
| 36 | SYSTEMD_TARGET=${SYSTEMD_DEFAULT_TARGET}" |
| 37 | |
| 38 | # Source code repository |
| 39 | S = "${WORKDIR}/git" |
| 40 | SRC_URI = "git://github.com/openbmc/phosphor-hostlogger" |
Andrew Geissler | a2c584b | 2019-02-14 07:42:17 +0000 | [diff] [blame] | 41 | SRCREV = "f780288ad8ce72e4ff924dada1c996ad1bddb2b8" |