blob: dfedab21acfd574a02aaca4631c384e858c646ee [file] [log] [blame]
Marri Devender Rao5a0088c2017-07-26 02:11:32 -05001SUMMARY = "To merge the Host and BMC config files generated from MRW "
2DESCRIPTION = "Merge host provided FRU info config file and \
3BMC accessible FRU info config files generated by \
4gen-ipmi-fru.pl into a single config file. fru-gen parser \
5parses the merged config file and generates cpp file"
6PR = "r1"
7
8inherit native
9inherit phosphor-ipmi-host
10inherit obmc-phosphor-license
11
12DEPENDS += "virtual/phosphor-ipmi-fru-read-inventory"
13DEPENDS += "virtual/phosphor-ipmi-fru-read-bmc-inventory"
14PROVIDES += "virtual/phosphor-ipmi-fru-merge-config"
15
16do_install_append() {
17 SRC=${config_datadir}
18 DEST=${D}${config_datadir}
19 install -d ${DEST}
20 cat ${SRC}/config.yaml ${SRC}/bmc-fru-config.yaml > ${DEST}/fru_config.yaml
21}