Joel Stanley | bc3b51a | 2018-04-23 10:50:44 +0930 | [diff] [blame] | 1 | HOMEPAGE = "https://github.com/jk-ozlabs/uart-render-controller" |
| 2 | LICENSE = "GPLv2+" |
| 3 | |
| 4 | SRC_URI += "git://github.com/jk-ozlabs/uart-render-controller;branch=master" |
| 5 | SRC_URI += "file://uart-render-controller.service" |
| 6 | |
| 7 | PR = "r1" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc" |
| 10 | |
| 11 | inherit autotools |
| 12 | inherit pkgconfig |
| 13 | inherit systemd |
| 14 | |
| 15 | DEPENDS += "autoconf-archive-native" |
| 16 | DEPENDS += "systemd" |
| 17 | RDEPENDS_${PN} += "libsystemd" |
| 18 | RDEPENDS_${PN} += "fbterm" |
| 19 | |
| 20 | SRCREV = "14decab20f621c050760e5f3310f5a960cf21211" |
| 21 | PV = "0.1+git${SRCPV}" |
| 22 | |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | SYSTEMD_SERVICE_${PN} += "uart-render-controller.service" |
| 26 | |
| 27 | do_install_append() { |
| 28 | install -d ${D}${systemd_system_unitdir} |
| 29 | install -m 0644 ${WORKDIR}/uart-render-controller.service ${D}${systemd_system_unitdir}/ |
| 30 | } |