blob: 5ba1653284f3d8ced5b7f0a0f491a9316e16f405 [file] [log] [blame]
Matt Spinler23f28832016-09-07 13:39:18 -05001SUMMARY = "Phosphor Inventory Generation"
2DESCRIPTION = "Generates inventory data from the machine readable workbook"
3PR = "r1"
4
5S = "${WORKDIR}/git"
6
Matt Spinler6f5fba12016-09-13 16:20:01 -05007PROVIDES += "virtual/obmc-inventory-data"
8RPROVIDES_${PN} += "virtual-obmc-inventory-data"
Matt Spinler23f28832016-09-07 13:39:18 -05009
10inherit allarch
11inherit obmc-phosphor-license
12
13DEPENDS += "mrw-native mrw-api-native"
14
15SRC_URI += "git://github.com/openbmc/phosphor-mrw-tools"
Patrick Williamsd1d2e072016-09-23 09:00:04 -050016SRCREV = "1e3881219bca043fbb1cd65445a62ee2afc1e0c6"
Matt Spinler23f28832016-09-07 13:39:18 -050017
18FILES_${PN} += "${datadir}/inventory"
19
20do_compile() {
21 ${STAGING_BINDIR_NATIVE}/perl-native/perl ${S}/inventory.pl \
22 -x ${STAGING_DATADIR_NATIVE}/obmc-mrw/${MACHINE}.xml -o inventory.json
23}
24
25do_install() {
26 install -d ${D}${datadir}/inventory
27 install -m 0644 inventory.json ${D}${datadir}/inventory/inventory.json
28}