blob: 87eaa4bad5ea0898a8618cf6046064826c1f5b6d [file] [log] [blame]
Ratan Guptac194c862018-04-24 18:10:36 +05301SUMMARY = "SNMP Manager Configuration"
2DESCRIPTION = "SNMP Manager Configuration."
3HOMEPAGE = "http://github.com/openbmc/phosphor-snmp"
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6
7inherit autotools pkgconfig
8inherit pythonnative
9inherit obmc-phosphor-dbus-service
10
11LICENSE = "Apache-2.0"
12LIC_FILES_CHKSUM = "file://${WORKDIR}/git/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
13
14SRC_URI += "git://github.com/openbmc/phosphor-snmp"
Andrew Geisslera59222c2018-10-05 03:50:34 +000015SRCREV = "ce714f4080c5ac1c9e0861520e1243ecbbb3b918"
Ratan Guptac194c862018-04-24 18:10:36 +053016
17DBUS_SERVICE_${PN} += "xyz.openbmc_project.Network.SNMP.service"
18
19DEPENDS += "systemd"
20DEPENDS += "autoconf-archive-native"
21DEPENDS += "sdbusplus sdbusplus-native"
22DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
23DEPENDS += "phosphor-logging"
24DEPENDS += "net-snmp"
25
26RDEPENDS_${PN} += "libsystemd"
27RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
28RDEPENDS_${PN} += "phosphor-logging"
Alexander Filippov51897172018-09-10 09:47:35 +030029RDEPENDS_${PN} += "net-snmp-lib-netsnmp"
Ratan Guptac194c862018-04-24 18:10:36 +053030
31S = "${WORKDIR}/git"