blob: 5bef75b069b33f86a2bf98a49fed2a25a7195a2b [file] [log] [blame]
Brad Bishopb0c3b272017-01-11 11:12:32 -05001SUMMARY = "OpenBMC hwmon poller"
2DESCRIPTION = "OpenBMC hwmon poller."
3PR = "r1"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
7
Brad Bishop030da252017-01-11 15:30:07 -05008inherit autotools pkgconfig obmc-phosphor-systemd
9
Brad Bishop1d34ddd2017-08-01 21:33:30 -040010PACKAGE_BEFORE_PN = "max31785-msl"
11SYSTEMD_PACKAGES = "${PN} max31785-msl"
12
Brad Bishop030da252017-01-11 15:30:07 -050013SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Hwmon@.service"
Brad Bishop1d34ddd2017-08-01 21:33:30 -040014SYSTEMD_SERVICE_max31785-msl = "phosphor-max31785-msl@.service"
Brad Bishopb0c3b272017-01-11 11:12:32 -050015
16DEPENDS += "autoconf-archive-native"
Brad Bishopf4393bf2017-02-20 14:36:31 -050017DEPENDS += " \
18 sdbusplus \
19 phosphor-dbus-interfaces \
20 phosphor-logging \
21 "
22
Brad Bishopb0c3b272017-01-11 11:12:32 -050023
24RDEPENDS_${PN} += "\
Brad Bishopf4393bf2017-02-20 14:36:31 -050025 sdbusplus \
26 phosphor-dbus-interfaces \
27 phosphor-logging \
Joel Stanley7b29e202017-09-05 17:44:33 +100028 bash \
Brad Bishopb0c3b272017-01-11 11:12:32 -050029 "
30
Brad Bishopfe7871c2017-02-22 20:50:13 -050031RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_phosphor-hwmon-config}"
32
Brad Bishop1d34ddd2017-08-01 21:33:30 -040033FILES_max31785-msl = "${bindir}/max31785-msl"
34RDEPENDS_max31785-msl = "${VIRTUAL-RUNTIME_base-utils} i2c-tools"
35
Brad Bishopb0c3b272017-01-11 11:12:32 -050036SRC_URI += "git://github.com/openbmc/phosphor-hwmon"
Brad Bishop030da252017-01-11 15:30:07 -050037SRC_URI += "file://70-hwmon.rules"
Brandon Wyman675ce0b2017-06-21 16:32:56 -050038SRC_URI += "file://70-iio.rules"
Joel Stanley7b29e202017-09-05 17:44:33 +100039SRC_URI += "file://start_hwmon.sh"
Brad Bishopb0c3b272017-01-11 11:12:32 -050040
Andrew Geisslerb3f5dc22018-03-23 13:40:12 +000041SRCREV = "a23babd6952cb21397d6aa408a827047d1de81de"
Brad Bishopb0c3b272017-01-11 11:12:32 -050042
43S = "${WORKDIR}/git"
Brad Bishop030da252017-01-11 15:30:07 -050044
45do_install_append() {
46
Brad Bishopf5812fd2017-01-26 09:12:57 -050047 install -d ${D}/${base_libdir}/udev/rules.d/
48 install ${WORKDIR}/70-hwmon.rules ${D}/${base_libdir}/udev/rules.d/
Brandon Wyman675ce0b2017-06-21 16:32:56 -050049 install ${WORKDIR}/70-iio.rules ${D}/${base_libdir}/udev/rules.d/
Joel Stanley7b29e202017-09-05 17:44:33 +100050
51 install -d ${D}${bindir}
52 install -m 0755 ${WORKDIR}/start_hwmon.sh ${D}${bindir}
Brad Bishop030da252017-01-11 15:30:07 -050053}