George Hung | e904d47 | 2020-09-25 07:55:30 +0800 | [diff] [blame] | 1 | SUMMARY = "Phosphor BMC Memory ECC Logging" |
| 2 | DESCRIPTION = "Daemon to monitor and report the BMC memory ECC" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 5 | PR = "r1" |
| 6 | |
| 7 | inherit meson pkgconfig |
| 8 | inherit systemd |
| 9 | |
| 10 | DEPENDS += "sdbusplus" |
| 11 | DEPENDS += "phosphor-dbus-interfaces" |
| 12 | DEPENDS += "sdeventplus" |
| 13 | DEPENDS += "phosphor-logging" |
| 14 | |
| 15 | RDEPENDS_${PN} += "phosphor-sel-logger" |
| 16 | |
| 17 | SRC_URI = "git://github.com/openbmc/phosphor-ecc.git" |
Andrew Geissler | e1ce7f5 | 2020-09-30 11:31:13 +0000 | [diff] [blame] | 18 | SRCREV = "0841f8abf9b38f981d443ecc552cc2b014764bbf" |
George Hung | e904d47 | 2020-09-25 07:55:30 +0800 | [diff] [blame] | 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | SYSTEMD_SERVICE_${PN} = " ${PN}.service" |