Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenBMC gdbus library" |
| 2 | DESCRIPTION = "libopenbmc_intf provides a set of gpio access \ |
| 3 | methods and the GDBUS skeleton code for the org.openbmc DBUS API." |
| 4 | PR = "r1" |
Patrick Venture | 9115011 | 2018-10-23 08:59:23 -0700 | [diff] [blame] | 5 | PV = "1.0+git${SRCPV}" |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 6 | |
| 7 | inherit skeleton |
Saqib Khan | c896e75 | 2017-11-13 10:47:54 -0600 | [diff] [blame] | 8 | inherit pkgconfig |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 9 | |
| 10 | DEPENDS += "glib-2.0" |
Matt Spinler | 728258c | 2018-08-07 16:35:19 -0500 | [diff] [blame] | 11 | DEPENDS += "cjson" |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 12 | |
| 13 | SKELETON_DIR = "libopenbmc_intf" |
| 14 | |
Matt Spinler | 728258c | 2018-08-07 16:35:19 -0500 | [diff] [blame] | 15 | SRC_URI += "file://gpio_defs.json" |
| 16 | |
Andrew Geissler | 2642059 | 2020-07-14 13:41:21 -0500 | [diff] [blame] | 17 | # Users of libopenbmc_intf use custom makefiles that do not |
| 18 | # support the proper library version detection and linking. |
| 19 | # Because of that, a link must be created within the |
| 20 | # rootfs for applicaitons to use this library. |
| 21 | # This next line tells bitbake to skip the check which |
| 22 | # ensures no links are put in the rootfs |
| 23 | INSANE_SKIP_${PN} += "dev-so" |
| 24 | |
| 25 | # Ensure the library is not in the dev package |
| 26 | FILES_SOLIBSDEV = "" |
| 27 | |
| 28 | # Now add the link to the production package |
| 29 | FILES_${PN} += "${libdir}/libopenbmc_intf.so" |
| 30 | |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 31 | do_install() { |
| 32 | oe_runmake install DESTDIR=${D} |
Matt Spinler | 728258c | 2018-08-07 16:35:19 -0500 | [diff] [blame] | 33 | |
| 34 | install -d ${D}${sysconfdir}/default/obmc/gpio/ |
| 35 | install -m 0644 ${WORKDIR}/gpio_defs.json ${D}/${sysconfdir}/default/obmc/gpio/ |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 36 | } |