Brad Bishop | 19ee51f | 2019-05-13 13:45:49 -0400 | [diff] [blame] | 1 | SUMMARY = "Generate fan control YAML from the MRW" |
| 2 | PR = "r1" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | |
| 5 | inherit allarch |
| 6 | inherit phosphor-fan |
| 7 | inherit mrw-xml |
| 8 | |
| 9 | S = "${WORKDIR}" |
| 10 | DEPENDS = "mrw-native mrw-perl-tools-native" |
| 11 | PROVIDES += "virtual/phosphor-fan-control-fan-config" |
| 12 | |
| 13 | do_compile() { |
| 14 | ${bindir}/perl-native/perl \ |
| 15 | ${bindir}/gen_fan_zone_yaml.pl \ |
| 16 | -i ${STAGING_DIR_NATIVE}${mrw_datadir}/${MRW_XML} \ |
| 17 | -o fans.yaml |
| 18 | } |
| 19 | |
| 20 | do_install() { |
| 21 | install -D fans.yaml ${D}${control_datadir}/fans.yaml |
| 22 | } |
| 23 | |
| 24 | FILES_${PN} += "${control_datadir}/fans.yaml" |