William A. Kennington III | fb85bf9 | 2019-05-16 01:05:58 -0700 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
2 | SRC_URI += "file://10-nice.conf" | ||||
3 | |||||
4 | inherit systemd | ||||
5 | |||||
6 | FILES_${PN} += "${systemd_unitdir}/system/rngd.service.d" | ||||
7 | |||||
8 | do_install_append() { | ||||
9 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then | ||||
10 | install -d ${D}${systemd_unitdir}/system/rngd.service.d | ||||
11 | install -m 644 ${WORKDIR}/10-nice.conf ${D}${systemd_unitdir}/system/rngd.service.d | ||||
12 | fi | ||||
13 | } |