blob: c1de313d66bb9e28ed31c70d523ec03038b309af [file] [log] [blame]
Joel Stanley79d16532016-03-21 12:24:40 +10301DESCRIPTION = "Linux kernel for OpenBMC"
2SECTION = "kernel"
3LICENSE = "GPLv2"
4
5KBRANCH ?= "dev-4.4"
6KCONFIG_MODE="--alldefconfig"
7
8SRC_URI = "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}"
9
10LINUX_VERSION ?= "4.4"
11LINUX_VERSION_EXTENSION ?= "-${SRCREV}"
12
Joel Stanley847af562016-05-18 14:38:38 +093013SRCREV="openbmc-20160518-1"
Joel Stanley79d16532016-03-21 12:24:40 +103014
15PV = "${LINUX_VERSION}+git${SRCPV}"
16
17COMPATIBLE_MACHINE_${MACHINE} = "openbmc"
18
19inherit kernel
20require recipes-kernel/linux/linux-yocto.inc