blob: 7b45d15d15245f3ce20b0df45d659cd77be29611 [file] [log] [blame]
Tom Joseph5a1a1ed2020-06-19 12:59:53 +05301SUMMARY = "Service configuration manager daemon to control the service"
2DESCRIPTION = "Applications must use service manager daemon to configure \
3 phosphor-ipmi-net, bmcweb, obmc-console etc in the system, \
4 instead of directly controlling the same using 'systemd' or \
5 'iptables'."
6
7PR = "r1"
8PV = "1.0+git${SRCPV}"
9
10inherit meson pkgconfig systemd
11
12require srvcfg-manager.inc
13
14S = "${WORKDIR}/git"
15SYSTEMD_SERVICE_${PN} = "srvcfg-manager.service"
16
17DEPENDS += " \
18 boost \
19 phosphor-logging \
20 sdbusplus \
21 sdbusplus-native \
22 systemd \
23 "