blob: 55ebe57791db12ea46dd765ec694b6c1320e89ad [file] [log] [blame]
Eddie James1a623ef2018-02-09 11:59:18 -06001SUMMARY = "Insecure private key for testing and development"
2DESCRIPTION = "Do not use this key to sign images."
3PR = "r1"
4
5inherit allarch
6inherit native
7inherit obmc-phosphor-license
8
9SRC_URI += "file://OpenBMC.priv"
10
11do_install() {
12 bbplain "Using an insecure image signing key!"
13 install -d ${D}${datadir}
14 install -m 400 ${WORKDIR}/OpenBMC.priv ${D}${datadir}
15}