Chris Austen | 0b14d30 | 2015-11-05 20:18:09 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor ipmi tool for injecting ipmi commands" |
| 2 | DESCRIPTION = "IPMI Tool with dbus capabilities" |
| 3 | HOMEPAGE = "https://github.com/openbmc/ipmitool" |
| 4 | PR = "r1" |
| 5 | |
| 6 | |
| 7 | RRECOMMENDS_${PN} = "virtual/obmc-phosphor-host-ipmi-hw" |
| 8 | |
| 9 | inherit obmc-phosphor-license |
| 10 | |
| 11 | DEPENDS += "systemd \ |
| 12 | host-ipmid \ |
| 13 | " |
| 14 | |
| 15 | RDEPENDS_${PN} += "libsystemd \ |
| 16 | libcrypto \ |
| 17 | " |
| 18 | |
| 19 | |
| 20 | SRC_URI += "git://github.com/openbmc/ipmitool" |
| 21 | |
| 22 | SRCREV = "e9b9c1a9677a3de19726d036cfb07d8d61bbccd8" |
| 23 | |
| 24 | |
| 25 | S = "${WORKDIR}/git" |
| 26 | |
| 27 | |
| 28 | do_compile() { |
| 29 | ${S}/bootstrap --enable-intf-dbus |
| 30 | ${S}/configure --host x86_64 |
| 31 | make |
| 32 | } |
| 33 | |
| 34 | do_install() { |
| 35 | install -m 0755 -d ${D}${sbindir} |
| 36 | install -m 0755 ${S}/src/ipmitool ${D}${sbindir} |
| 37 | } |