blob: bf55058de6fcd720db1910a4883390c230951a56 [file] [log] [blame]
Matt Spinler3578d902018-06-21 14:23:47 -05001SUMMARY = "Copy error yaml files to known path for elog parsing"
2PR = "r1"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
5
6inherit native
7inherit phosphor-dbus-yaml
8
9require phosphor-software-manager.inc
10
11S = "${WORKDIR}/git"
12
13do_install_append() {
14 SRC=${S}/xyz/openbmc_project/Software/
15 DEST=${D}${yaml_dir}/xyz/openbmc_project/Software/
16 install -d ${DEST}
17 install ${SRC}/*.errors.yaml ${DEST}
18 install ${SRC}/*.metadata.yaml ${DEST}
19}