blob: 7899dc45831731b2eb39a9c6a0e1b5f98b6d17ee [file] [log] [blame]
Matthew Barth91460422017-02-24 13:14:43 -06001SUMMARY = "Phosphor Fan Presence"
2DESCRIPTION = "Phosphor fan presence provides a set of fan presence \
3daemons to monitor fan presence changes by different methods of \
4presence detection."
5HOMEPAGE = "https://github.com/openbmc/phosphor-fan-presence"
6PR = "r1"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10inherit autotools pkgconfig pythonnative
11inherit obmc-phosphor-systemd
12
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "python-pyyaml-native"
15DEPENDS += "sdbusplus"
16DEPENDS += "phosphor-logging"
17RDEPENDS_${PN} += "sdbusplus"
18
19FAN_PRESENCE_PACKAGES = " \
20 ${PN}-tach \
21"
22PACKAGES_remove = "${PN}"
23PACKAGES += "${FAN_PRESENCE_PACKAGES}"
24SYSTEMD_PACKAGES = "${FAN_PRESENCE_PACKAGES}"
25RDEPENDS_${PN}-dev = "${FAN_PRESENCE_PACKAGES}"
26
27# Needed to install into the obmc-chassis-start target
28TMPL = "phosphor-fan-presence-tach@.service"
29INSTFMT = "phosphor-fan-presence-tach@{0}.service"
30TGTFMT = "obmc-chassis-start@{0}.target"
31FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
32
33FILES_${PN}-tach = "${sbindir}/phosphor-fan-presence-tach"
34SYSTEMD_SERVICE_${PN}-tach += "${TMPL}"
35SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
36
37SRC_URI += "git://github.com/openbmc/phosphor-fan-presence"
38SRCREV = "5c15b797ffafd36eceecfbf250bd0eead39103dd"
39
40S = "${WORKDIR}/git"