blob: 41d4913eb8a987a2ccad49bdf94adfffb0c48b9f [file] [log] [blame]
Cyril Bur9a3f0082017-01-12 18:13:30 +11001SUMMARY = "Phosphor OpenBMC MBOX Daemon"
2DESCRIPTION = "Phosphor OpenBMC MBOX Daemon"
3PR = "r1"
Patrick Venture281a99e2018-10-21 08:26:38 -07004PV = "1.0+git${SRCPV}"
Cyril Bur9a3f0082017-01-12 18:13:30 +11005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
7
8inherit autotools pkgconfig
9inherit obmc-phosphor-systemd
10
11DEPENDS += "autoconf-archive-native"
Andrew Jeffery928084f2017-04-21 10:18:24 +093012DEPENDS += "systemd"
Patrick Williamsea61a042017-06-30 12:01:49 -050013DEPENDS += "phosphor-logging"
Andrew Jefferyaef4ced2017-04-18 16:30:10 +093014RDEPENDS_${PN} += "libsystemd"
Cyril Bur9a3f0082017-01-12 18:13:30 +110015
16S = "${WORKDIR}/git"
17
Adriana Kobylaka38f5d92018-09-10 11:44:29 -050018SRC_URI += "git://github.com/openbmc/mboxbridge.git"
Cyril Bur9a3f0082017-01-12 18:13:30 +110019
20SRC_URI += "file://99-aspeed-mbox.rules"
Andrew Jefferya944a4b2017-01-25 13:17:13 +103021SRC_URI += "file://99-aspeed-lpc-ctrl.rules"
Cyril Bur9a3f0082017-01-12 18:13:30 +110022SRC_URI += "file://aspeed-lpc-ctrl-h.patch"
23
Andrew Geissler1a30f7c2018-11-28 05:10:28 +000024SRCREV="fd4fa34d5680b68d0669f5e3a799556f0d73a9c1"
Andrew Jefferyaef4ced2017-04-18 16:30:10 +093025
26PROVIDES += "mboxctl"
Cyril Bur9a3f0082017-01-12 18:13:30 +110027
28MBOXD_FLASH_SIZE ??= "32M"
29SYSTEMD_SUBSTITUTIONS += "FLASH_SIZE:${MBOXD_FLASH_SIZE}:${PN}.service"
30
31# Hacks because ${STAGING_KERNEL_DIR} points to the kernel source tree, not the
32# installed, pre-processed headers. Requires the aspeed-lpc-ctrl-h patch above.
Saqib Khanbe0ee8e2017-03-09 10:28:09 -060033CFLAGS_append = " -I include"
Cyril Bur9a3f0082017-01-12 18:13:30 +110034
35do_install_append() {
36 install -d ${D}/lib/udev/rules.d
37 install -m 0644 ${WORKDIR}/99-aspeed-mbox.rules ${D}/lib/udev/rules.d
Andrew Jefferya944a4b2017-01-25 13:17:13 +103038 install -m 0644 ${WORKDIR}/99-aspeed-lpc-ctrl.rules ${D}/lib/udev/rules.d
Cyril Bur9a3f0082017-01-12 18:13:30 +110039}
Matt Spinlerf96194c2017-01-20 15:32:07 -060040
41TMPL = "mboxd-reload@.service"
Andrew Geissler4a9dbb22017-07-25 09:12:37 -050042TGTFMT = "obmc-chassis-poweron@{0}.target"
Matt Spinlerf96194c2017-01-20 15:32:07 -060043INSTFMT = "mboxd-reload@{0}.service"
44FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
45
46SYSTEMD_SERVICE_${PN} += "mboxd.service"
47SYSTEMD_SERVICE_${PN} += "mboxd-reload@.service"
48SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
Deepak Kodihallie1aa7fd2017-06-29 09:56:24 -050049
Brad Bishop168ce612018-03-09 00:40:41 -050050# Enable virtual-pnor by DISTRO_FEATURE openpower-ubi-fs.
51PACKAGECONFIG_append_df-openpower-ubi-fs = "virtual-pnor"
Patrick Williams6d641c52017-08-09 16:36:51 -050052PACKAGECONFIG[virtual-pnor] = "--enable-virtual-pnor,--disable-virtual-pnor"