blob: f15fc73d39a52856bcba59684ae68b61b0e7648d [file] [log] [blame]
Marri Devender Rao139b3732018-10-09 07:53:30 -05001SUMMARY = "Phosphor certificate manager configuration for an nslcd authority service"
2
3PR = "r1"
4
5LICENSE = "Apache-2.0"
Brad Bishopa1cee092019-09-13 12:14:05 -04006LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Marri Devender Rao139b3732018-10-09 07:53:30 -05007
Brad Bishop1a4e65e2019-03-21 19:08:15 -04008RDEPENDS_${PN} = "phosphor-certificate-manager"
Marri Devender Rao139b3732018-10-09 07:53:30 -05009
10inherit allarch
Marri Devender Rao139b3732018-10-09 07:53:30 -050011
Brad Bishop1a4e65e2019-03-21 19:08:15 -040012SRC_URI = "file://env"
13
14do_install() {
15 install -D ${WORKDIR}/env ${D}/${sysconfdir}/default/obmc/cert/authority
16}
17
18pkg_postinst_${PN}() {
19 LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@authority.service"
20 TARGET="../phosphor-certificate-manager@.service"
21 mkdir -p $D$systemd_system_unitdir/multi-user.target.wants
22 ln -s $TARGET $LINK
23}
24
25pkg_prerm_${PN}() {
26 LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@authority.service"
27 rm $LINK
28}