blob: dd6da478346cc95ceb3efdf18d16231bef35b6e0 [file] [log] [blame]
Kuiying Wang0d737652018-11-08 16:52:49 +08001SUMMARY = "OpenBMC Buttons"
2DESCRIPTION = "OpenBMC All buttons"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
7
8S = "${WORKDIR}/git"
9SRC_URI += "git://github.com/openbmc/phosphor-buttons.git"
Andrew Geissler443f1b02018-12-10 19:00:27 +000010SRCREV = "391a21a1bb002a62ce336bfacdd8fdf888b7909a"
Kuiying Wang0d737652018-11-08 16:52:49 +080011
12inherit cmake pkgconfig systemd
13
14SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Chassis.Buttons.service"
15
16DEPENDS += " \
17 systemd \
18 sdbusplus \
19 phosphor-dbus-interfaces \
20 phosphor-logging \
21 nlohmann-json \
22 gpioplus \
23 "