blob: cde6004fd18794d7c33fa1e2664217d935fec6e3 [file] [log] [blame]
Andrew Geissler9f8770e2017-01-10 15:12:03 -06001SUMMARY = "Phosphor Host State Management"
2DESCRIPTION = "Phosphor Host State Manager provides a host state \
3object which manages the hosts in the system. It is suitable for use on \
4a wide variety of OpenBMC platforms."
5HOMEPAGE = "https://github.com/openbmc/phosphor-state-manager"
6PR = "r1"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10inherit autotools pkgconfig
11inherit obmc-phosphor-dbus-service
12
13DBUS_SERVICE_${PN} += "xyz.openbmc_project.State.Host.service"
14
15RDEPENDS_${PN} += "libsystemd"
16DEPENDS += "autoconf-archive-native"
17DEPENDS += "sdbusplus"
18DEPENDS += "phosphor-logging"
19
20PROVIDES += "virtual/obmc-host-state-mgmt"
21RPROVIDES_${PN} += "virtual-obmc-host-state-mgmt"
22
23SRC_URI += "git://github.com/openbmc/phosphor-state-manager"
24SRCREV = "794baed325213d39d75e5f8c3374177891ef70ec"
25
26S = "${WORKDIR}/git"