Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenBMC state manager" |
| 2 | DESCRIPTION = "OpenBMC state manager." |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit skeleton-python |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 6 | inherit obmc-phosphor-systemd |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 7 | |
| 8 | VIRTUAL-RUNTIME_skeleton_workbook ?= "" |
| 9 | |
| 10 | RDEPENDS_${PN} += "\ |
| 11 | python-dbus \ |
| 12 | python-json \ |
| 13 | python-subprocess \ |
| 14 | python-pygobject \ |
| 15 | " |
| 16 | |
| 17 | SKELETON_DIR = "pystatemgr" |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 18 | SYSTEMD_SERVICE_${PN} += "obmc-mgr-state.service obmc-mgr-state.target" |
| 19 | |
| 20 | TMPL = "mapper-wait@.service" |
| 21 | TGT = "obmc-mgr-state.target" |
| 22 | HOST_FMT = "../${TMPL}:${TGT}.wants/mapper-wait@-org-openbmc-settings-host{0}.service" |
| 23 | CHASSIS_FMT = "../${TMPL}:${TGT}.wants/mapper-wait@-org-openbmc-control-chassis{0}.service" |
| 24 | POWER_FMT = "../${TMPL}:${TGT}.wants/mapper-wait@-org-openbmc-control-power{0}.service" |
| 25 | |
| 26 | SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'HOST_FMT', 'OBMC_HOST_INSTANCES')}" |
| 27 | SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'CHASSIS_FMT', 'OBMC_CHASSIS_INSTANCES')}" |
| 28 | SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'POWER_FMT', 'OBMC_POWER_INSTANCES')}" |