blob: b0709587ad497e8de5a7b0f56a803e372be1e8e0 [file] [log] [blame]
Brad Bishop86ee1cf2016-06-27 14:53:52 -04001SUMMARY = "OpenBMC PCIE slot detection utility"
2DESCRIPTION = "OpenBMC PCIE slot detection utility."
3PR = "r1"
4
5inherit skeleton-gdbus
Brad Bishop0fe80462016-08-17 20:27:37 -04006inherit obmc-phosphor-systemd
Brad Bishop86ee1cf2016-06-27 14:53:52 -04007
8SKELETON_DIR = "pciedetect"
Brad Bishop0fe80462016-08-17 20:27:37 -04009
10TMPL = "pcie-slot-detect@.service"
Josh D. Kinga283e072017-04-06 15:56:37 -050011TGTFMT = "obmc-host-start@{0}.target"
Brad Bishop0fe80462016-08-17 20:27:37 -040012INSTFMT = "pcie-slot-detect@{0}.service"
13FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
14
15SYSTEMD_SERVICE_${PN} += "pcie-slot-detect@.service"
16SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"