blob: 47dc2a4a1aff7b7b050ceaa067999abeb8d0c02f [file] [log] [blame]
Matt Spinlerc943de32017-03-21 15:02:13 -05001SUMMARY = "Generate fan presence YAML from the MRW"
2PR = "r1"
3
4inherit native
5inherit obmc-phosphor-license
Brad Bishop2c5ba172017-04-22 16:26:22 -04006inherit phosphor-fan
Matt Spinler3f6fcbe2017-12-14 13:31:55 -06007inherit mrw-xml
Matt Spinlerc943de32017-03-21 15:02:13 -05008
9DEPENDS += " \
10 mrw-native \
11 mrw-perl-tools-native \
12 "
13
14PROVIDES += "virtual/phosphor-fan-presence-config"
15
16S = "${WORKDIR}"
17
18do_install() {
19 DEST=${D}${presence_datadir}
20 install -d ${DEST}
21
22 ${bindir}/perl-native/perl \
23 ${bindir}/gen_presence_yaml.pl \
Matt Spinler3f6fcbe2017-12-14 13:31:55 -060024 -i ${mrw_datadir}/${MRW_XML} \
Matt Spinlerc943de32017-03-21 15:02:13 -050025 -o ${DEST}/config.yaml
26}