Matt Spinler | 0b96a4e | 2016-08-12 12:52:36 -0500 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC machine readable workbook API modules" |
| 2 | DESCRIPTION = "The API for the MRW XML generated by the Serverwiz tool" |
| 3 | PR = "r1" |
| 4 | |
| 5 | S = "${WORKDIR}/scripts" |
| 6 | |
| 7 | inherit obmc-phosphor-license |
| 8 | inherit native |
| 9 | inherit perlnative |
| 10 | inherit cpan-base |
Matt Spinler | de33cae | 2016-09-15 10:39:43 -0500 | [diff] [blame] | 11 | inherit mrw-rev |
Matt Spinler | 0b96a4e | 2016-08-12 12:52:36 -0500 | [diff] [blame] | 12 | |
| 13 | DEPENDS += "libxml-simple-perl-native json-perl-native" |
| 14 | |
Matt Spinler | de33cae | 2016-09-15 10:39:43 -0500 | [diff] [blame] | 15 | SRC_URI += "${MRW_API_SRC_URI}" |
| 16 | SRCREV = "${MRW_API_SRCREV}" |
Matt Spinler | 0b96a4e | 2016-08-12 12:52:36 -0500 | [diff] [blame] | 17 | |
| 18 | do_install() { |
Matt Spinler | 471b885 | 2016-09-20 13:32:44 -0500 | [diff] [blame] | 19 | install -d ${D}${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw |
| 20 | install -m 0755 Targets.pm ${D}${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw/Targets.pm |
Matt Spinler | 0b96a4e | 2016-08-12 12:52:36 -0500 | [diff] [blame] | 21 | } |