blob: aec28c2af1874b76e54f64afd935eac60e3be538 [file] [log] [blame]
Chris Austen0b14d302015-11-05 20:18:09 -06001SUMMARY = "Phosphor ipmi tool for injecting ipmi commands"
2DESCRIPTION = "IPMI Tool with dbus capabilities"
3HOMEPAGE = "https://github.com/openbmc/ipmitool"
4PR = "r1"
5
6
Brad Bishopa7156812016-09-06 22:02:03 -04007RRECOMMENDS_${PN} = "virtual-obmc-host-ipmi-hw"
Chris Austen0b14d302015-11-05 20:18:09 -06008
9inherit obmc-phosphor-license
10
11DEPENDS += "systemd \
12 host-ipmid \
13 "
14
15RDEPENDS_${PN} += "libsystemd \
16 libcrypto \
17 "
18
19
20SRC_URI += "git://github.com/openbmc/ipmitool"
21
22SRCREV = "e9b9c1a9677a3de19726d036cfb07d8d61bbccd8"
23
24
25S = "${WORKDIR}/git"
26
27
28do_compile() {
29 ${S}/bootstrap --enable-intf-dbus
30 ${S}/configure --host x86_64
31 make
32}
33
34do_install() {
35 install -m 0755 -d ${D}${sbindir}
36 install -m 0755 ${S}/src/ipmitool ${D}${sbindir}
37}