blob: 65175bf0fb29a86d82c213e368d66efa32ec7491 [file] [log] [blame]
Matt Spinler23f28832016-09-07 13:39:18 -05001SUMMARY = "Phosphor Inventory Generation"
2DESCRIPTION = "Generates inventory data from the machine readable workbook"
3PR = "r1"
4
5S = "${WORKDIR}/git"
6
Matt Spinler6f5fba12016-09-13 16:20:01 -05007PROVIDES += "virtual/obmc-inventory-data"
8RPROVIDES_${PN} += "virtual-obmc-inventory-data"
Matt Spinler23f28832016-09-07 13:39:18 -05009
10inherit allarch
11inherit obmc-phosphor-license
12
13DEPENDS += "mrw-native mrw-api-native"
14
15SRC_URI += "git://github.com/openbmc/phosphor-mrw-tools"
Patrick Williamsa9606be2016-10-03 22:20:04 -050016SRCREV = "9596f9a92c7ddd83face8bb9cd5540a4633c2bc6"
Matt Spinler23f28832016-09-07 13:39:18 -050017
18FILES_${PN} += "${datadir}/inventory"
19
20do_compile() {
21 ${STAGING_BINDIR_NATIVE}/perl-native/perl ${S}/inventory.pl \
22 -x ${STAGING_DATADIR_NATIVE}/obmc-mrw/${MACHINE}.xml -o inventory.json
23}
24
25do_install() {
26 install -d ${D}${datadir}/inventory
27 install -m 0644 inventory.json ${D}${datadir}/inventory/inventory.json
28}