blob: c1eb3c9e70b4d74824160a7f8d7bc56065fa18be [file] [log] [blame]
Brad Bishop1bb8be52016-06-08 22:03:59 -04001# Common code for systemd based services.
2#
3# Prior to inheriting this class, recipes can define services like this:
4#
5# SYSTEMD_SERVICE_${PN} = "foo.service bar.socket baz@.service"
6#
7# and these files will be added to the main package if they exist.
8#
9# Alternatively this class can just be inherited and
Brad Bishop8b875602016-07-11 00:42:58 -040010# ${PN}.service will be added to the main package.
Brad Bishop7aeda7b2016-07-11 13:05:26 -040011#
12# Other variables:
13# INHIBIT_SYSTEMD_RESTART_POLICY_${unit}
14# Inhibit the warning that is displayed if a service unit without a
15# restart policy is detected.
Brad Bishopb7e2a882016-07-14 19:34:06 -040016#
Brad Bishop975b2cd2016-08-17 12:08:16 -040017# SYSTEMD_SUBSTITUTIONS_${path-relative-to-system_unitdir}
18# Variables in this list will be substituted in the specified
Brad Bishopb7e2a882016-07-14 19:34:06 -040019# file during install (if bitbake finds python {format} strings
Brad Bishop975b2cd2016-08-17 12:08:16 -040020# in the file itself). List entries take the form:
Brad Bishopb7e2a882016-07-14 19:34:06 -040021# VAR:VALUE
22# where {VAR} is the format string bitbake should look for in the
Brad Bishop975b2cd2016-08-17 12:08:16 -040023# file and VALUE is the value to substitute.
Brad Bishop039c66b2016-07-14 19:50:19 -040024#
Brad Bishopbcd1b652016-08-15 22:35:58 -040025# SYSTEMD_USER_${PN}.service = "foo"
26# SYSTEMD_USER_${unit}.service = "foo"
27# The user for the unit/package.
Brad Bishopb7e2a882016-07-14 19:34:06 -040028
Brad Bishopbfef6ff2016-07-07 15:56:02 -040029
30inherit obmc-phosphor-utils
Brad Bishop93fb5352015-09-09 03:59:20 +000031inherit systemd
Brad Bishop039c66b2016-07-14 19:50:19 -040032inherit useradd
Brad Bishop93fb5352015-09-09 03:59:20 +000033
Brad Bishopbfef6ff2016-07-07 15:56:02 -040034_INSTALL_SD_UNITS=""
Brad Bishopb7e2a882016-07-14 19:34:06 -040035SYSTEMD_DEFAULT_TARGET ?= "obmc-standby.target"
Brad Bishopbfef6ff2016-07-07 15:56:02 -040036
Brad Bishop039c66b2016-07-14 19:50:19 -040037# Big ugly hack to prevent useradd.bbclass post-parse sanity checker failure.
38# If there are users to be added, we'll add them in our post-parse.
39# If not...there don't seem to be any ill effects...
40USERADD_PACKAGES ?= " "
41USERADD_PARAM_${PN} ?= ";"
42
Brad Bishop1bb8be52016-06-08 22:03:59 -040043
Brad Bishopb1ebc602016-08-16 08:18:07 -040044def SystemdUnit(unit):
45 class Unit(object):
46 def __init__(self, unit):
47 self.unit = unit
Brad Bishop7aeda7b2016-07-11 13:05:26 -040048
Brad Bishopb1ebc602016-08-16 08:18:07 -040049 def __getattr__(self, item):
50 if item is 'name':
51 return self.unit
52 if item is 'is_activated':
53 return self.unit.startswith('dbus-')
54 if item is 'is_template':
55 return '@.' in self.unit
56 if item is 'is_instance':
57 return '@' in self.unit and not self.is_template
58 if item in ['is_service', 'is_target']:
59 return self.unit.split('.')[-1] == item
60 if item is 'base':
61 cls = self.unit.split('.')[-1]
62 base = self.unit.replace('dbus-', '')
63 base = base.replace('.%s' % cls, '')
64 if self.is_instance:
65 base = base.rstrip('@%s' % self.instance)
66 if self.is_template:
67 base = base.rstrip('@')
68 return base
69 if item is 'instance' and self.is_instance:
70 inst = self.unit.rsplit('@')[-1]
71 return inst.rsplit('.')[0]
72 if item is 'template' and self.is_instance:
73 cls = self.unit.split('.')[-1]
74 return '%s@.%s' % (self.base, cls)
75 if item is 'template' and self.is_template:
76 return '.'.join(self.base.split('@')[:-1])
Brad Bishop7aeda7b2016-07-11 13:05:26 -040077
Brad Bishopb1ebc602016-08-16 08:18:07 -040078 raise AttributeError(item)
79 return Unit(unit)
Brad Bishop7aeda7b2016-07-11 13:05:26 -040080
81
82def systemd_parse_unit(d, path):
83 import ConfigParser
84 parser = ConfigParser.SafeConfigParser()
85 parser.optionxform = str
86 parser.read('%s' % path)
87 return parser
88
89
Brad Bishop1bb8be52016-06-08 22:03:59 -040090python() {
Brad Bishop7aeda7b2016-07-11 13:05:26 -040091 def check_sd_unit(d, unit):
Brad Bishopbfef6ff2016-07-07 15:56:02 -040092 searchpaths = d.getVar('FILESPATH', True)
Brad Bishopb1ebc602016-08-16 08:18:07 -040093 path = bb.utils.which(searchpaths, '%s' % unit.name)
Brad Bishopbfef6ff2016-07-07 15:56:02 -040094 if not os.path.isfile(path):
Brad Bishopb1ebc602016-08-16 08:18:07 -040095 bb.fatal('Did not find unit file "%s"' % unit.name)
Brad Bishop7aeda7b2016-07-11 13:05:26 -040096
97 parser = systemd_parse_unit(d, path)
98 inhibit = listvar_to_list(d, 'INHIBIT_SYSTEMD_RESTART_POLICY_WARNING')
Brad Bishopb1ebc602016-08-16 08:18:07 -040099 if unit.is_service and \
100 not unit.is_template and \
101 unit.name not in inhibit and \
Brad Bishop7aeda7b2016-07-11 13:05:26 -0400102 not parser.has_option('Service', 'Restart'):
103 bb.warn('Systemd unit \'%s\' does not '
Brad Bishopb1ebc602016-08-16 08:18:07 -0400104 'have a restart policy defined.' % unit.name)
Brad Bishop7aeda7b2016-07-11 13:05:26 -0400105
106
107 def add_sd_unit(d, unit, pkg):
Brad Bishopb1ebc602016-08-16 08:18:07 -0400108 name = unit.name
Brad Bishop975b2cd2016-08-17 12:08:16 -0400109 unit_dir = d.getVar('systemd_system_unitdir', True)
Brad Bishopb1ebc602016-08-16 08:18:07 -0400110 set_append(d, 'SRC_URI', 'file://%s' % name)
111 set_append(d, 'FILES_%s' % pkg, '%s/%s' % (unit_dir, name))
112 set_append(d, '_INSTALL_SD_UNITS', name)
113 set_append(d, '_MAKE_SUBS', '%s' % name)
Brad Bishop7aeda7b2016-07-11 13:05:26 -0400114
Brad Bishopb7e2a882016-07-14 19:34:06 -0400115 for x in [
116 'base_bindir',
117 'bindir',
118 'sbindir',
119 'SYSTEMD_DEFAULT_TARGET' ]:
Brad Bishopb1ebc602016-08-16 08:18:07 -0400120 set_append(d, 'SYSTEMD_SUBSTITUTIONS_%s' % name,
Brad Bishopb7e2a882016-07-14 19:34:06 -0400121 '%s:%s' % (x, d.getVar(x, True)))
122
Brad Bishop039c66b2016-07-14 19:50:19 -0400123
124 def add_sd_user(d, unit, pkg):
Brad Bishopb1ebc602016-08-16 08:18:07 -0400125 name = unit.name
Brad Bishop039c66b2016-07-14 19:50:19 -0400126 opts = [
127 '--system',
128 '--home',
129 '/',
130 '--no-create-home',
131 '--shell /sbin/nologin',
132 '--user-group']
133
Brad Bishopb1ebc602016-08-16 08:18:07 -0400134 var = 'SYSTEMD_USER_%s' % name
Brad Bishopbcd1b652016-08-15 22:35:58 -0400135 user = listvar_to_list(d, var)
136 if len(user) is 0:
137 var = 'SYSTEMD_USER_%s' % pkg
138 user = listvar_to_list(d, var)
139 if len(user) is not 0:
140 if len(user) is not 1:
141 bb.fatal('Too many users assigned to %s: \'%s\'' % (var, ' '.join(user)))
142
143 user = user[0]
Brad Bishopb1ebc602016-08-16 08:18:07 -0400144 set_append(d, 'SYSTEMD_SUBSTITUTIONS_%s' % name,
Brad Bishopbcd1b652016-08-15 22:35:58 -0400145 'USER:%s' % user)
146 if user not in d.getVar('USERADD_PARAM_%s' % pkg, True):
147 set_append(
148 d,
149 'USERADD_PARAM_%s' % pkg,
150 '%s' % (' '.join(opts + [user])),
151 ';')
Brad Bishop039c66b2016-07-14 19:50:19 -0400152 if pkg not in d.getVar('USERADD_PACKAGES', True):
153 set_append(d, 'USERADD_PACKAGES', pkg)
154
Brad Bishopbfef6ff2016-07-07 15:56:02 -0400155
Brad Bishop8b875602016-07-11 00:42:58 -0400156 pn = d.getVar('PN', True)
Brad Bishopbfef6ff2016-07-07 15:56:02 -0400157 if d.getVar('SYSTEMD_SERVICE_%s' % pn, True) is None:
158 d.setVar('SYSTEMD_SERVICE_%s' % pn, '%s.service' % pn)
Brad Bishop1bb8be52016-06-08 22:03:59 -0400159
Brad Bishopbfef6ff2016-07-07 15:56:02 -0400160 for pkg in listvar_to_list(d, 'SYSTEMD_PACKAGES'):
Brad Bishopb1ebc602016-08-16 08:18:07 -0400161 svc = listvar_to_list(d, 'SYSTEMD_SERVICE_%s' % pkg)
162 svc = [SystemdUnit(x) for x in svc]
163 tmpl = [x.template for x in svc if x.is_instance]
164 tmpl = list(set(tmpl))
165 tmpl = [SystemdUnit(x) for x in tmpl]
166 svc = [x for x in svc if not x.is_instance]
167
168 for unit in tmpl + svc:
Brad Bishop7aeda7b2016-07-11 13:05:26 -0400169 check_sd_unit(d, unit)
Brad Bishopbfef6ff2016-07-07 15:56:02 -0400170 add_sd_unit(d, unit, pkg)
Brad Bishop039c66b2016-07-14 19:50:19 -0400171 add_sd_user(d, unit, pkg)
Brad Bishop1bb8be52016-06-08 22:03:59 -0400172}
Brad Bishop93fb5352015-09-09 03:59:20 +0000173
Brad Bishopbfef6ff2016-07-07 15:56:02 -0400174
Brad Bishopb7e2a882016-07-14 19:34:06 -0400175python systemd_do_postinst() {
Brad Bishop975b2cd2016-08-17 12:08:16 -0400176 for f in listvar_to_list(d, '_MAKE_SUBS'):
Brad Bishopb7e2a882016-07-14 19:34:06 -0400177 subs = dict([ x.split(':') for x in
Brad Bishop975b2cd2016-08-17 12:08:16 -0400178 listvar_to_list(d, 'SYSTEMD_SUBSTITUTIONS_%s' % f)])
Brad Bishopb7e2a882016-07-14 19:34:06 -0400179 if not subs:
180 continue
181
182 path = d.getVar('D', True)
183 path += d.getVar('systemd_system_unitdir', True)
Brad Bishop975b2cd2016-08-17 12:08:16 -0400184 path += '/%s' % f
Brad Bishopb7e2a882016-07-14 19:34:06 -0400185 with open(path, 'r') as fd:
186 content = fd.read()
187 with open(path, 'w+') as fd:
188 try:
189 fd.write(content.format(**subs))
190 except KeyError as e:
191 bb.fatal('No substitution found for %s in '
Brad Bishop975b2cd2016-08-17 12:08:16 -0400192 'file \'%s\'' % (e, f))
Brad Bishopb7e2a882016-07-14 19:34:06 -0400193}
194
195
Brad Bishop93fb5352015-09-09 03:59:20 +0000196do_install_append() {
Brad Bishop1bb8be52016-06-08 22:03:59 -0400197 # install systemd service/socket/template files
Brad Bishopbfef6ff2016-07-07 15:56:02 -0400198 [ -z "${_INSTALL_SD_UNITS}" ] || \
Brad Bishop1bb8be52016-06-08 22:03:59 -0400199 install -d ${D}${systemd_system_unitdir}
Brad Bishopbfef6ff2016-07-07 15:56:02 -0400200 for s in ${_INSTALL_SD_UNITS}; do
201 install -m 0644 ${WORKDIR}/$s \
202 ${D}${systemd_system_unitdir}/$s
Brad Bishop1bb8be52016-06-08 22:03:59 -0400203 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
204 -e 's,@BINDIR@,${bindir},g' \
205 -e 's,@SBINDIR@,${sbindir},g' \
206 ${D}${systemd_system_unitdir}/$s
207 done
Brad Bishop93fb5352015-09-09 03:59:20 +0000208}
Brad Bishopb7e2a882016-07-14 19:34:06 -0400209
210
211do_install[postfuncs] += "systemd_do_postinst"