Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 1 | SUMMARY = "Phosphor LED Group Management meta data" |
| 2 | PR = "r1" |
| 3 | |
| 4 | inherit obmc-phosphor-utils |
| 5 | inherit obmc-phosphor-license |
| 6 | |
| 7 | # Default is the example set of data. |
| 8 | PHOSPHOR_LED_MANAGER_CONFIG ??= "${PN}-example-native" |
| 9 | |
| 10 | # Choose appropriate yaml file |
| 11 | def get_depends(d): |
| 12 | if d.getVar('USE_MRW', 'yes'): |
| 13 | return "${PN}-mrw-native" |
| 14 | else: |
| 15 | return "${PHOSPHOR_LED_MANAGER_CONFIG}" |
| 16 | |
Brad Bishop | b943d91 | 2017-01-31 10:37:13 -0500 | [diff] [blame] | 17 | USE_MRW = "${@cf_enabled(d, 'obmc-mrw', 'yes')}" |
Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 18 | DEPENDS += "${@get_depends(d)}" |