Vishwanatha Subbanna | 0489833 | 2017-01-09 16:02:27 +0530 | [diff] [blame] | 1 | SUMMARY = "Phosphor Physical LED Controller daemon" |
| 2 | DESCRIPTION = "Daemon to trigger actions on a physical LED" |
| 3 | HOMEPAGE = "http://github.com/openbmc/phosphor-led-sysfs" |
| 4 | PR = "r1" |
| 5 | |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 8 | inherit autotools pkgconfig |
Brad Bishop | 66038f4 | 2017-01-26 12:36:52 -0500 | [diff] [blame] | 9 | inherit obmc-phosphor-dbus-service |
Vishwanatha Subbanna | 0489833 | 2017-01-09 16:02:27 +0530 | [diff] [blame] | 10 | |
| 11 | DEPENDS += "autoconf-archive-native" |
| 12 | DEPENDS += "sdbusplus" |
| 13 | RDEPENDS_${PN} += "libsystemd" |
| 14 | |
Brad Bishop | 66038f4 | 2017-01-26 12:36:52 -0500 | [diff] [blame] | 15 | DBUS_SERVICE_${PN} += "xyz.openbmc_project.led.controller@.service" |
| 16 | |
Vishwanatha Subbanna | 0489833 | 2017-01-09 16:02:27 +0530 | [diff] [blame] | 17 | SRC_URI += "git://github.com/openbmc/phosphor-led-sysfs" |
Brad Bishop | 66038f4 | 2017-01-26 12:36:52 -0500 | [diff] [blame] | 18 | SRC_URI += "file://70-leds.rules" |
Patrick Williams | a66cc2b | 2017-02-20 08:00:05 -0600 | [diff] [blame] | 19 | SRCREV = "179b671d90a945a7e6e843ff208c4067e45709a4" |
Vishwanatha Subbanna | 0489833 | 2017-01-09 16:02:27 +0530 | [diff] [blame] | 20 | S = "${WORKDIR}/git" |
Brad Bishop | 66038f4 | 2017-01-26 12:36:52 -0500 | [diff] [blame] | 21 | |
| 22 | do_install_append() { |
| 23 | install -d ${D}/${base_libdir}/udev/rules.d/ |
| 24 | install ${WORKDIR}/70-leds.rules ${D}/${base_libdir}/udev/rules.d/ |
| 25 | } |