Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenBMC gdbus library" |
| 2 | DESCRIPTION = "libopenbmc_intf provides a set of gpio access \ |
| 3 | methods and the GDBUS skeleton code for the org.openbmc DBUS API." |
| 4 | PR = "r1" |
Patrick Venture | 9115011 | 2018-10-23 08:59:23 -0700 | [diff] [blame] | 5 | PV = "1.0+git${SRCPV}" |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 6 | |
| 7 | inherit skeleton |
Saqib Khan | c896e75 | 2017-11-13 10:47:54 -0600 | [diff] [blame] | 8 | inherit pkgconfig |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 9 | |
| 10 | DEPENDS += "glib-2.0" |
Matt Spinler | 728258c | 2018-08-07 16:35:19 -0500 | [diff] [blame] | 11 | DEPENDS += "cjson" |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 12 | |
| 13 | SKELETON_DIR = "libopenbmc_intf" |
| 14 | |
Matt Spinler | 728258c | 2018-08-07 16:35:19 -0500 | [diff] [blame] | 15 | SRC_URI += "file://gpio_defs.json" |
| 16 | |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 17 | do_install() { |
| 18 | oe_runmake install DESTDIR=${D} |
Matt Spinler | 728258c | 2018-08-07 16:35:19 -0500 | [diff] [blame] | 19 | |
| 20 | install -d ${D}${sysconfdir}/default/obmc/gpio/ |
| 21 | install -m 0644 ${WORKDIR}/gpio_defs.json ${D}/${sysconfdir}/default/obmc/gpio/ |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 22 | } |