Wenzong Fan | 9eb3f61 | 2015-08-14 03:11:24 -0400 | [diff] [blame] | 1 | SUMMARY = "Python module for handling IPv4 and IPv6 Addresses and Networks" |
| 2 | DESCRIPTION = "IPy is a Python module for handling IPv4 and IPv6 Addresses and Networks \ |
| 3 | in a fashion similar to perl's Net::IP and friends. The IP class allows \ |
| 4 | a comfortable parsing and handling for most notations in use for IPv4 \ |
| 5 | and IPv6 Addresses and Networks." |
| 6 | SECTION = "devel/python" |
| 7 | HOMEPAGE = "https://github.com/haypo/python-ipy" |
| 8 | DEPENDS = "python" |
| 9 | LICENSE = "BSD" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=ebc0028ff5cdaf7796604875027dcd55" |
| 11 | |
| 12 | SRC_URI = "http://pypi.python.org/packages/source/I/IPy/IPy-${PV}.tar.gz" |
| 13 | |
| 14 | SRC_URI[md5sum] = "7b8c6eb4111b15aea31b67108e769712" |
| 15 | SRC_URI[sha256sum] = "61da5a532b159b387176f6eabf11946e7458b6df8fb8b91ff1d345ca7a6edab8" |
| 16 | |
| 17 | S = "${WORKDIR}/IPy-${PV}" |
| 18 | |
| 19 | inherit distutils |
| 20 | |
| 21 | # need to export these variables for python-config to work |
| 22 | export BUILD_SYS |
| 23 | export HOST_SYS |
| 24 | export STAGING_INCDIR |
| 25 | export STAGING_LIBDIR |
| 26 | |
| 27 | BBCLASSEXTEND = "native" |
| 28 | |
| 29 | do_install_append() { |
| 30 | install -d ${D}/${datadir}/doc/${BPN}-${PV} |
| 31 | install AUTHORS COPYING ChangeLog README ${D}/${datadir}/doc/${BPN}-${PV} |
| 32 | } |