Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor State Management" |
| 2 | DESCRIPTION = "Phosphor State Manager provides a set of system state \ |
| 3 | management daemons. It is suitable for use on a wide variety of OpenBMC \ |
| 4 | platforms." |
| 5 | HOMEPAGE = "https://github.com/openbmc/phosphor-state-manager" |
| 6 | PR = "r1" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 9 | |
| 10 | STATE_MGR_PACKAGES = " \ |
| 11 | ${PN}-host \ |
| 12 | ${PN}-chassis \ |
Josh King | a946288 | 2017-01-19 14:04:03 -0600 | [diff] [blame] | 13 | ${PN}-bmc \ |
Michael Tritz | 7199d26 | 2017-04-18 17:01:12 -0500 | [diff] [blame] | 14 | ${PN}-discover \ |
Andrew Geissler | a94faf4 | 2017-05-08 15:58:01 -0500 | [diff] [blame] | 15 | ${PN}-host-check \ |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 16 | " |
| 17 | PACKAGES =+ "${STATE_MGR_PACKAGES}" |
Brad Bishop | c3f1057 | 2017-03-01 16:08:45 -0500 | [diff] [blame] | 18 | PACKAGES_remove = "${PN}" |
| 19 | RDEPENDS_${PN}-dev = "${STATE_MGR_PACKAGES}" |
| 20 | RDEPENDS_${PN}-staticdev = "${STATE_MGR_PACKAGES}" |
| 21 | |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 22 | DBUS_PACKAGES = "${STATE_MGR_PACKAGES}" |
| 23 | |
Michael Tritz | 1f792e0 | 2017-03-31 12:04:32 -0500 | [diff] [blame] | 24 | SYSTEMD_PACKAGES = "${PN}-discover" |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 25 | |
| 26 | inherit autotools pkgconfig |
| 27 | inherit obmc-phosphor-dbus-service |
| 28 | |
| 29 | DEPENDS += "autoconf-archive-native" |
| 30 | DEPENDS += "sdbusplus" |
| 31 | DEPENDS += "phosphor-logging" |
Patrick Williams | d0486d8 | 2017-01-30 11:06:16 -0600 | [diff] [blame] | 32 | DEPENDS += "phosphor-dbus-interfaces" |
Adriana Kobylak | a6fc67f | 2017-01-30 20:30:00 -0600 | [diff] [blame] | 33 | RDEPENDS_${PN} += "sdbusplus" |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 34 | |
Patrick Williams | d0486d8 | 2017-01-30 11:06:16 -0600 | [diff] [blame] | 35 | RDEPENDS_${PN}-host += "libsystemd phosphor-dbus-interfaces" |
| 36 | RDEPENDS_${PN}-chassis += "libsystemd phosphor-dbus-interfaces" |
| 37 | RDEPENDS_${PN}-bmc += "libsystemd phosphor-dbus-interfaces" |
Michael Tritz | 7199d26 | 2017-04-18 17:01:12 -0500 | [diff] [blame] | 38 | RDEPENDS_${PN}-discover += "libsystemd phosphor-dbus-interfaces" |
Andrew Geissler | a94faf4 | 2017-05-08 15:58:01 -0500 | [diff] [blame] | 39 | RDEPENDS_${PN}-host-check += "libsystemd phosphor-dbus-interfaces" |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 40 | |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 41 | FILES_${PN}-host = "${sbindir}/phosphor-host-state-manager" |
| 42 | DBUS_SERVICE_${PN}-host += "xyz.openbmc_project.State.Host.service" |
| 43 | |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 44 | FILES_${PN}-chassis = "${sbindir}/phosphor-chassis-state-manager" |
| 45 | DBUS_SERVICE_${PN}-chassis += "xyz.openbmc_project.State.Chassis.service" |
| 46 | |
Josh King | a946288 | 2017-01-19 14:04:03 -0600 | [diff] [blame] | 47 | FILES_${PN}-bmc = "${sbindir}/phosphor-bmc-state-manager" |
| 48 | DBUS_SERVICE_${PN}-bmc += "xyz.openbmc_project.State.BMC.service" |
| 49 | |
Michael Tritz | 7199d26 | 2017-04-18 17:01:12 -0500 | [diff] [blame] | 50 | FILES_${PN}-discover = "${sbindir}/phosphor-discover-system-state" |
Michael Tritz | 1f792e0 | 2017-03-31 12:04:32 -0500 | [diff] [blame] | 51 | SYSTEMD_SERVICE_${PN}-discover += "phosphor-discover-system-state@.service" |
| 52 | |
Andrew Geissler | a94faf4 | 2017-05-08 15:58:01 -0500 | [diff] [blame] | 53 | FILES_${PN}-host-check = "${sbindir}/phosphor-host-check" |
| 54 | SYSTEMD_SERVICE_${PN}-host-check += "phosphor-reset-host-check@.service" |
| 55 | SYSTEMD_SERVICE_${PN}-host-check += "phosphor-reset-host-running@.service" |
| 56 | |
| 57 | RESET_CHECK_TMPL = "phosphor-reset-host-check@.service" |
| 58 | RESET_CHECK_TGTFMT = "obmc-host-reset@{1}.target" |
| 59 | RESET_CHECK_INSTFMT = "phosphor-reset-host-check@{0}.service" |
| 60 | RESET_CHECK_FMT = "../${RESET_CHECK_TMPL}:${RESET_CHECK_TGTFMT}.requires/${RESET_CHECK_INSTFMT}" |
| 61 | |
| 62 | RESET_RUNNING_TMPL = "phosphor-reset-host-running@.service" |
| 63 | RESET_RUNNING_TGTFMT = "obmc-host-reset@{1}.target" |
| 64 | RESET_RUNNING_INSTFMT = "phosphor-reset-host-running@{0}.service" |
| 65 | RESET_RUNNING_FMT = "../${RESET_RUNNING_TMPL}:${RESET_RUNNING_TGTFMT}.requires/${RESET_RUNNING_INSTFMT}" |
| 66 | |
| 67 | SYSTEMD_LINK_${PN}-host-check += "${@compose_list_zip(d, 'RESET_CHECK_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_HOST_INSTANCES')}" |
| 68 | SYSTEMD_LINK_${PN}-host-check += "${@compose_list_zip(d, 'RESET_RUNNING_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_HOST_INSTANCES')}" |
| 69 | |
| 70 | # Force the standby target to run the host reset check target |
| 71 | RESET_TMPL_CTRL = "obmc-host-reset@.target" |
| 72 | SYSD_TGT = "${SYSTEMD_DEFAULT_TARGET}" |
| 73 | RESET_INSTFMT_CTRL = "obmc-host-reset@{0}.target" |
| 74 | RESET_FMT_CTRL = "../${RESET_TMPL_CTRL}:${SYSD_TGT}.wants/${RESET_INSTFMT_CTRL}" |
| 75 | SYSTEMD_LINK_${PN}-host-check += "${@compose_list_zip(d, 'RESET_FMT_CTRL', 'OBMC_HOST_INSTANCES')}" |
| 76 | |
Michael Tritz | 1f792e0 | 2017-03-31 12:04:32 -0500 | [diff] [blame] | 77 | TMPL = "phosphor-discover-system-state@.service" |
| 78 | INSTFMT = "phosphor-discover-system-state@{0}.service" |
| 79 | FMT = "../${TMPL}:${SYSTEMD_DEFAULT_TARGET}.wants/${INSTFMT}" |
| 80 | SYSTEMD_LINK_${PN}-discover += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}" |
Michael Tritz | 7199d26 | 2017-04-18 17:01:12 -0500 | [diff] [blame] | 81 | |
Andrew Geissler | 191400b | 2017-05-26 17:40:03 -0500 | [diff] [blame] | 82 | # Force the shutdown target to run the host-stop target |
| 83 | HOST_STOP_TMPL = "obmc-host-stop@.target" |
| 84 | HOST_STOP_TGTFMT = "obmc-host-shutdown@{1}.target" |
| 85 | HOST_STOP_INSTFMT = "obmc-host-stop@{0}.target" |
| 86 | HOST_STOP_FMT = "../${HOST_STOP_TMPL}:${HOST_STOP_TGTFMT}.requires/${HOST_STOP_INSTFMT}" |
| 87 | SYSTEMD_LINK_${PN}-host += "${@compose_list_zip(d, 'HOST_STOP_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_HOST_INSTANCES')}" |
| 88 | |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 89 | SRC_URI += "git://github.com/openbmc/phosphor-state-manager" |
Patrick Williams | 5f9bd61 | 2017-07-06 11:20:05 -0500 | [diff] [blame] | 90 | SRCREV = "181f8364f81fc8864e9ae86f28de13f80cd9bbf9" |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 91 | |
| 92 | S = "${WORKDIR}/git" |