Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor State Management" |
| 2 | DESCRIPTION = "Phosphor State Manager provides a set of system state \ |
| 3 | management daemons. It is suitable for use on a wide variety of OpenBMC \ |
| 4 | platforms." |
| 5 | HOMEPAGE = "https://github.com/openbmc/phosphor-state-manager" |
| 6 | PR = "r1" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 9 | |
| 10 | STATE_MGR_PACKAGES = " \ |
| 11 | ${PN}-host \ |
| 12 | ${PN}-chassis \ |
Josh King | a946288 | 2017-01-19 14:04:03 -0600 | [diff] [blame] | 13 | ${PN}-bmc \ |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 14 | " |
| 15 | PACKAGES =+ "${STATE_MGR_PACKAGES}" |
| 16 | DBUS_PACKAGES = "${STATE_MGR_PACKAGES}" |
| 17 | |
| 18 | # Set SYSTEMD_PACKAGES to empty because we do not want ${PN} and DBUS_PACKAGES |
| 19 | # handles the rest. |
| 20 | SYSTEMD_PACKAGES = "" |
| 21 | |
| 22 | inherit autotools pkgconfig |
| 23 | inherit obmc-phosphor-dbus-service |
| 24 | |
| 25 | DEPENDS += "autoconf-archive-native" |
| 26 | DEPENDS += "sdbusplus" |
| 27 | DEPENDS += "phosphor-logging" |
Patrick Williams | d0486d8 | 2017-01-30 11:06:16 -0600 | [diff] [blame] | 28 | DEPENDS += "phosphor-dbus-interfaces" |
Adriana Kobylak | a6fc67f | 2017-01-30 20:30:00 -0600 | [diff] [blame] | 29 | RDEPENDS_${PN} += "sdbusplus" |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 30 | |
Patrick Williams | d0486d8 | 2017-01-30 11:06:16 -0600 | [diff] [blame] | 31 | RDEPENDS_${PN}-host += "libsystemd phosphor-dbus-interfaces" |
| 32 | RDEPENDS_${PN}-chassis += "libsystemd phosphor-dbus-interfaces" |
| 33 | RDEPENDS_${PN}-bmc += "libsystemd phosphor-dbus-interfaces" |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 34 | |
| 35 | PROVIDES += "virtual/obmc-host-state-mgmt" |
| 36 | RPROVIDES_${PN}-host += "virtual-obmc-host-state-mgmt" |
| 37 | FILES_${PN}-host = "${sbindir}/phosphor-host-state-manager" |
| 38 | DBUS_SERVICE_${PN}-host += "xyz.openbmc_project.State.Host.service" |
| 39 | |
| 40 | PROVIDES += "virtual/obmc-chassis-state-mgmt" |
| 41 | RPROVIDES_${PN}-chassis += "virtual-obmc-chassis-state-mgmt" |
| 42 | FILES_${PN}-chassis = "${sbindir}/phosphor-chassis-state-manager" |
| 43 | DBUS_SERVICE_${PN}-chassis += "xyz.openbmc_project.State.Chassis.service" |
| 44 | |
Josh King | a946288 | 2017-01-19 14:04:03 -0600 | [diff] [blame] | 45 | PROVIDES += "virtual/obmc-bmc-state-mgmt" |
| 46 | RPROVIDES_${PN}-bmc += "virtual-obmc-bmc-state-mgmt" |
| 47 | FILES_${PN}-bmc = "${sbindir}/phosphor-bmc-state-manager" |
| 48 | DBUS_SERVICE_${PN}-bmc += "xyz.openbmc_project.State.BMC.service" |
| 49 | |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 50 | SRC_URI += "git://github.com/openbmc/phosphor-state-manager" |
Patrick Williams | bb52a2d | 2017-02-14 16:10:05 -0600 | [diff] [blame] | 51 | SRCREV = "d3e58474dad16a9e215df1687f72dd9f80f0c231" |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 52 | |
| 53 | S = "${WORKDIR}/git" |