blob: 1eadadf52218defd2e89d1ff242ca7b5cec3c255 [file] [log] [blame]
Matt Spinlerb89b9e72017-04-17 16:34:24 -05001SUMMARY = "Generate fan control YAML from the MRW"
2PR = "r1"
3
4inherit native
5inherit obmc-phosphor-license
6inherit phosphor-fan
7
8DEPENDS += " \
9 mrw-native \
10 mrw-perl-tools-native \
11 "
12
13PROVIDES += "virtual/phosphor-fan-control-fan-config"
14
15S = "${WORKDIR}"
16
17do_compile() {
18 ${bindir}/perl-native/perl \
19 ${bindir}/gen_fan_zone_yaml.pl \
20 -i ${datadir}/obmc-mrw/${MACHINE}.xml \
21 -o ${S}/fans.yaml
22}
23
24do_install() {
25 DEST=${D}${control_datadir}
26 install -D ${S}/fans.yaml ${DEST}/fans.yaml
27}