blob: 87943ea0461d130901cae5d075d3dd1f8cfcb2f5 [file] [log] [blame]
Ed Tanous2fe7ba02018-05-31 15:07:49 -07001SUMMARY = "Phosphor OpenBMC KCS to DBUS"
2DESCRIPTION = "Phosphor OpenBMC KCS to DBUS."
3PR = "r1"
4
Yong Lib8bfdc02018-12-04 21:40:17 +08005LICENSE = "Apache-2.0"
Ed Tanous2fe7ba02018-05-31 15:07:49 -07006LIC_FILES_CHKSUM = "file://LICENSE;md5=b1beb00e508e89da1ed2a541934f28c0"
7
8inherit autotools pkgconfig
9inherit obmc-phosphor-dbus-service
10
11PV = "1.0+git${SRCPV}"
12
13KCS_DEVICE ?= "ipmi-kcs3"
14
15DBUS_SERVICE_${PN} = "org.openbmc.HostIpmi.service"
16SYSTEMD_SUBSTITUTIONS += "KCS_DEVICE:${KCS_DEVICE}:${DBUS_SERVICE_${PN}}"
17
18PROVIDES += "virtual/obmc-host-ipmi-hw"
19RPROVIDES_${PN} += "virtual-obmc-host-ipmi-hw"
20RRECOMMENDS_${PN} += "phosphor-ipmi-host"
21
22DEPENDS += " \
23 autoconf-archive-native \
24 systemd \
25 "
26RDEPENDS_${PN} += "libsystemd"
27
28S = "${WORKDIR}/git"
29SRC_URI = "git://github.com/openbmc/kcsbridge.git;protocol=https"
Andrew Geissler628e7c02018-09-18 16:00:24 +000030SRCREV = "ccf086f151b30d792efec493021fd862f9b3e77e"
Ed Tanous2fe7ba02018-05-31 15:07:49 -070031
32# This is how linux-libc-headers says to include custom uapi headers
33CFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include/uapi"
34do_configure[depends] += "virtual/kernel:do_shared_workdir"