Jason M. Bills | b2911ec | 2018-10-26 14:07:48 -0700 | [diff] [blame] | 1 | SUMMARY = "Journal IPMI SEL Logger" |
| 2 | DESCRIPTION = "Utility to write IPMI SEL records to the journal" |
| 3 | |
| 4 | # SEL Logger has the ability to monitor and automatically log SEL records for |
| 5 | # various types of events, but this is disabled by default. The following |
| 6 | # flags can be set in a .bbappend to enable specific types of event |
| 7 | # monitoring: |
| 8 | # |
| 9 | # SEL_LOGGER_MONITOR_THRESHOLD_EVENTS: |
| 10 | # Monitors and logs SEL records for threshold sensor events |
| 11 | |
| 12 | inherit cmake systemd |
| 13 | S = "${WORKDIR}/git/" |
| 14 | |
| 15 | LICENSE = "Apache-2.0" |
| 16 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 17 | |
| 18 | DEPENDS += "systemd sdbusplus boost phosphor-ipmi-host" |
| 19 | |
| 20 | SRC_URI = "git://github.com/openbmc/phosphor-sel-logger.git;protocol=git" |
Andrew Geissler | cfc8ba0 | 2019-03-27 23:32:12 +0000 | [diff] [blame] | 21 | SRCREV = "bb071fb5baac164435672a42fec7ed2c10ea4503" |
Jason M. Bills | b2911ec | 2018-10-26 14:07:48 -0700 | [diff] [blame] | 22 | |
| 23 | PV = "0.1+git${SRCPV}" |
| 24 | |
| 25 | SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Logging.IPMI.service" |