Matt Spinler | 7274afc | 2016-08-26 14:34:57 -0500 | [diff] [blame] | 1 | DESCRIPTION = " *************************** CAUTION \ |
| 2 | ************************************** * \ |
| 3 | * \ |
| 4 | * INCOMPATIBLE CHANGE (JSON::XS version 2.90) \ |
| 5 | * \ |
| 6 | * \ |
| 7 | * \ |
| 8 | * JSON.pm had patched JSON::XS::Boolean and JSON::PP::Boolean \ |
| 9 | internally * \ |
| 10 | * on loading time for making these modules inherit JSON::Boolean. \ |
| 11 | * \ |
| 12 | * But since JSON::XS v3.0 it use Types::Serialiser as boolean class. \ |
| 13 | * \ |
| 14 | * Then now JSON.pm breaks boolean classe overload features and \ |
| 15 | * \ |
| 16 | * -support_by_pp if JSON::XS v3.0 or later is installed. \ |
| 17 | * \ |
| 18 | * \ |
| 19 | * \ |
| 20 | * JSON::true and JSON::false returned JSON::Boolean objects. \ |
| 21 | * \ |
| 22 | * For workaround, they return JSON::PP::Boolean objects in this \ |
| 23 | version. * \ |
| 24 | * \ |
| 25 | * \ |
| 26 | * isa_ok(JSON::true, 'JSON::PP::Boolean'); \ |
| 27 | * \ |
| 28 | * \ |
| 29 | * \ |
| 30 | * And it discards a feature: \ |
| 31 | * \ |
| 32 | * \ |
| 33 | * \ |
| 34 | * ok(JSON::true eq 'true'); \ |
| 35 | * \ |
| 36 | * \ |
| 37 | * \ |
| 38 | * In other word, JSON::PP::Boolean overload numeric only. \ |
| 39 | * \ |
| 40 | * \ |
| 41 | * \ |
| 42 | * ok( JSON::true == 1 ); \ |
| 43 | * \ |
| 44 | * \ |
| 45 | * \ |
| 46 | \ |
| 47 | *********************************************************************** \ |
| 48 | ***" |
| 49 | |
| 50 | SECTION = "libs" |
| 51 | LICENSE = "Artistic-1.0 | GPL-2.0" |
| 52 | PR = "r0" |
| 53 | |
| 54 | MAINTAINER= "Poky <poky@yoctoproject.org>" |
| 55 | HOMEPAGE= "https://metacpan.org/release/JSON" |
| 56 | |
| 57 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \ |
| 58 | file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" |
| 59 | |
| 60 | SRC_URI = "http://cpan.metacpan.org/authors/id/M/MA/MAKAMAKA/JSON-2.90.tar.gz" |
| 61 | |
| 62 | SRC_URI[md5sum] = "e1512169a623e790a3f69b599cc1d3b9" |
| 63 | SRC_URI[sha256sum] = "4ddbb3cb985a79f69a34e7c26cde1c81120d03487e87366f9a119f90f7bdfe88" |
| 64 | |
| 65 | S = "${WORKDIR}/JSON-${PV}" |
| 66 | |
| 67 | inherit cpan |
| 68 | |
| 69 | do_compile() { |
| 70 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 71 | cpan_do_compile |
| 72 | } |
| 73 | |
| 74 | BBCLASSEXTEND = "native" |