blob: cda8e0b51bea7f75b6c4dada2050fdfd63cb0d1e [file] [log] [blame]
Leonel Gonzalez3562b952017-04-11 08:27:58 -05001
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3
4SRC_URI += "file://rngd.service"
5
6inherit systemd
7
8SYSTEMD_SERVICE_${PN} = "rngd.service"
9
10do_install_append() {
11 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
12 install -d ${D}${systemd_unitdir}/system
13 install -m 644 ${WORKDIR}/rngd.service ${D}${systemd_unitdir}/system
14 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/rngd.service
15 fi
16}
17