blob: 267fc9296de4d6258c3231bd6fb9b91fcc108baf [file] [log] [blame]
Matt Spinlerc943de32017-03-21 15:02:13 -05001SUMMARY = "Generate fan presence YAML from the MRW"
2PR = "r1"
3
4inherit native
5inherit obmc-phosphor-license
6inherit phosphor-fan-presence
7
8DEPENDS += " \
9 mrw-native \
10 mrw-perl-tools-native \
11 "
12
13PROVIDES += "virtual/phosphor-fan-presence-config"
14
15S = "${WORKDIR}"
16
17do_install() {
18 DEST=${D}${presence_datadir}
19 install -d ${DEST}
20
21 ${bindir}/perl-native/perl \
22 ${bindir}/gen_presence_yaml.pl \
23 -i ${datadir}/obmc-mrw/${MACHINE}.xml \
24 -o ${DEST}/config.yaml
25}