blob: 464cf110a4d0b5e0f33dcd9dd6ddcd8d7f26cf22 [file] [log] [blame]
Brad Bishop86ee1cf2016-06-27 14:53:52 -04001SUMMARY = "OpenBMC state manager"
2DESCRIPTION = "OpenBMC state manager."
3PR = "r1"
4
5inherit skeleton-python
Brad Bishop0fe80462016-08-17 20:27:37 -04006inherit obmc-phosphor-systemd
Brad Bishop86ee1cf2016-06-27 14:53:52 -04007
8VIRTUAL-RUNTIME_skeleton_workbook ?= ""
9
10RDEPENDS_${PN} += "\
11 python-dbus \
12 python-json \
13 python-subprocess \
14 python-pygobject \
15 "
16
17SKELETON_DIR = "pystatemgr"
Brad Bishop0fe80462016-08-17 20:27:37 -040018SYSTEMD_SERVICE_${PN} += "obmc-mgr-state.service obmc-mgr-state.target"
19
20TMPL = "mapper-wait@.service"
21TGT = "obmc-mgr-state.target"
22HOST_FMT = "../${TMPL}:${TGT}.wants/mapper-wait@-org-openbmc-settings-host{0}.service"
23CHASSIS_FMT = "../${TMPL}:${TGT}.wants/mapper-wait@-org-openbmc-control-chassis{0}.service"
24POWER_FMT = "../${TMPL}:${TGT}.wants/mapper-wait@-org-openbmc-control-power{0}.service"
25
26SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'HOST_FMT', 'OBMC_HOST_INSTANCES')}"
27SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'CHASSIS_FMT', 'OBMC_CHASSIS_INSTANCES')}"
28SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'POWER_FMT', 'OBMC_POWER_INSTANCES')}"