Vishwanatha Subbanna | 78bc542 | 2016-11-10 21:52:46 +0530 | [diff] [blame] | 1 | SUMMARY = "Phosphor Time Manager daemon" |
| 2 | DESCRIPTION = "Daemon to cater to BMC and HOST time management" |
| 3 | HOMEPAGE = "http://github.com/openbmc/phosphor-time-manager" |
| 4 | PR = "r1" |
| 5 | |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
Lei YU | f499a54 | 2017-07-04 10:02:28 +0800 | [diff] [blame] | 8 | inherit autotools pkgconfig pythonnative |
Vishwanatha Subbanna | a906ca3 | 2017-01-11 02:19:41 -0600 | [diff] [blame] | 9 | inherit obmc-phosphor-dbus-service |
Vishwanatha Subbanna | 78bc542 | 2016-11-10 21:52:46 +0530 | [diff] [blame] | 10 | |
| 11 | DEPENDS += "autoconf-archive-native" |
| 12 | DEPENDS += "phosphor-mapper" |
| 13 | DEPENDS += "systemd" |
Lei YU | f499a54 | 2017-07-04 10:02:28 +0800 | [diff] [blame] | 14 | DEPENDS += "sdbusplus" |
| 15 | DEPENDS += "sdbusplus-native" |
| 16 | DEPENDS += "phosphor-logging" |
| 17 | DEPENDS += "phosphor-dbus-interfaces" |
Vishwanatha Subbanna | ef5e5dd | 2017-01-11 03:50:12 -0600 | [diff] [blame] | 18 | RDEPENDS_${PN} += "virtual-obmc-settings-mgmt" |
Vishwanatha Subbanna | 78bc542 | 2016-11-10 21:52:46 +0530 | [diff] [blame] | 19 | RDEPENDS_${PN} += "network" |
| 20 | RDEPENDS_${PN} += "libmapper" |
| 21 | RDEPENDS_${PN} += "libsystemd" |
Lei YU | f499a54 | 2017-07-04 10:02:28 +0800 | [diff] [blame] | 22 | RDEPENDS_${PN} += "sdbusplus" |
| 23 | RDEPENDS_${PN} += "phosphor-dbus-interfaces" |
Vishwanatha Subbanna | ade547d | 2017-01-11 02:46:25 -0600 | [diff] [blame] | 24 | |
Vishwanatha Subbanna | 78bc542 | 2016-11-10 21:52:46 +0530 | [diff] [blame] | 25 | SRC_URI += "git://github.com/openbmc/phosphor-time-manager" |
Lei YU | f499a54 | 2017-07-04 10:02:28 +0800 | [diff] [blame] | 26 | SRCREV = "debe1d8f47bab3d61b3340c84f802f1dc6388ca0" |
Vishwanatha Subbanna | 78bc542 | 2016-11-10 21:52:46 +0530 | [diff] [blame] | 27 | S = "${WORKDIR}/git" |
| 28 | |
Lei YU | f499a54 | 2017-07-04 10:02:28 +0800 | [diff] [blame] | 29 | DBUS_SERVICE_${PN} += "xyz.openbmc_project.Time.Manager.service" |